Android adb server version (32) doesn’t match this client (Genymotion)

Probably you have seen this type of error when using Genymotion as the Android emulator on which you test your device. This is how the error looks like:

adb server version (32) doesn’t match this client (35); killing…
error: could not install *smartsocket* listener: Address already in use
ADB server didn’t ACK
* failed to start daemon *

There is one simple thing that worked for me. I opened the Settings menu of Genymotion, then ADB tab and selected: Use custom android SDK tools and I set the path to the tools. By default Genymotion uses its built-in tools. After that killing all working emulators and starting them again makes everything  work.

Hope I have helped!

You may also like...

  • Good, it helped me too… Keep posting. Thank you 🙂

  • ash

    Wow… Tats Bulls eye.. Thanks Buddy

  • Anuj

    hey, i have the same problem i done the same thing that mentioned above but is not work for me.

    • n0m0r3pa1n

      Hey,
      are you sure you have selected the right SDK folder and have you downloaded the latest version?